System Requirements

Modified on Thu, 11 Jul at 10:32 AM

System Requirements

There are multiple ways to use the DSim simulator: locally and in the cloud, from the terminal, and through the DSim Desktop UI. Depending on how you use the DSim simulator, different system requirements apply from the product requirements below.


The common system requirements are:



Hardware

  • 1.6 GHz or faster x86 or x64 processor
  • 1 GB of RAM
  • 500 MB of disk space

Internet Browsers

Browser Supported Version(s)
Chrome Latest
Firefox Latest
Edge Latest
Safari Latest

WSL

WSL (Windows Subsystem for Linux) provides a Linux environment on Windows. If you are not familiar with running Linux applications in WSL with and without VSCode, we recommed sticking with the native Windows.



DSim Desktop

Below is a list of supported operating systems and shells for DSim Desktop. The items in the tables below are those Metrics is testing with on a regular basis.



Operating Systems

Operating System Distribution Supported Version(s)
Windows 64-bit 10, 11
Linux CentOS 8
Linux Debian 10
Linux Ubuntu 20.04

macOS is not supported at this time.



Shells

Operating System Shell
Windows PowerShell, Microsoft Windows Terminal, DSim Desktop
Linux bash

DSim

Below is a list of supported operating systems and shells for DSim. The items in the tables below are those Metrics is testing with on a regular basis.



Operating Systems

Operating System Distribution Supported Version(s)
Windows - 10, 11
Linux CentOS 8, 9
Linux Debian 10, 11
Linux Ubuntu 20.04, 22.04

macOS is not supported at this time.


For Linux installations, a script called check_dependencies.sh is provided in the DSim installation directory in ~/metrics-ca/dsim/<version>/. We recommend you run the script as it will make suggestions about any packages that need installing. You will need to run these commands with sudo if you are not the root user.


For example, open a shell terminal and run:


 

%> cd ~/metrics-ca/dsim/<version>
%> ./check_dependencies.sh

 

The script will make suggestions like the following as needed:


 

Please install the missing packages with the following commands.
You will be required to respond to questions or you can add '-y'
to the end of each command to answer yes to all questions.
(Note: these must be run as the root user or prefixed with sudo)
    apt update
    apt install binutils

 

Again, you'll need sudo or be the root user. If you are not the root user, then the you must be a user with sudo permission and then you can run:


 

%> sudo apt update
%> sudo apt install binutils

 


Shells

Operating System Shell
Windows PowerShell, Microsoft Windows Terminal, DSim Desktop
Linux bash

DSim Cloud

Below is a list of supported operating systems and shells for DSim Cloud. The items in the tables below are those Metrics is testing with on a regular basis.


If you are using an unsupported OS, DSim Cloud may likely work. However, we are not testing internally for it.



Operating Systems

Operating System Distribution Supported Version(s)
Windows - 10+
macOS - Latest major release
Previous major release
Linux Debian Latest major release
Previous major release
Linux Ubuntu Latest major release
Previous major release

* An issue has been found with Ubuntu 22.04 whereby the DSim Cloud CLI will not operate after installation. Running the mdc --version command will return the following error:


 

%> mdc --version  
No usable version of libssl was found  
Aborted (core dumped)

 

To install libssl onto Ubuntu, please perform the following steps, which should clear the issue.


 

%> echo"deb http://security.ubuntu.com/ubuntu impish-security main" | sudo tee /etc/apt/sources.list.d/impish-security.list
%> sudo apt-get update
%> sudo apt-get install libssl1.1

 


Shells

Operating System Shell
Windows PowerShell, Microsoft Windows Terminal, DSim Desktop
macOS bash
Linux bash

Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select at least one of the reasons
CAPTCHA verification is required.

Feedback sent

We appreciate your effort and will try to fix the article