DSim Cloud CLI commands not recognized by Windows

Modified on Tue, 9 Jul at 6:07 PM

DSim Cloud CLI commands not recognized by Windows

Problem:

After installing the DSim Cloud CLI, Windows may not recognize DSim Cloud CLI commands, with messages like the following when DSim Cloud CLI commands are attempted:


 

Program 'mdc.exe' failed to run: Operation did not complete successfully  
because the file contains a virus or potentially unwanted software

 


 

mdc : The term 'mdc' is not recognized as the name of a cmdlet,  
function, script file, or operable program. Check the spelling of the name,  
or if a path was included, verify that the path is correct and try again.

 


Solution:

There are several possible solutions, depending on the cause.


If the DSim Cloud install directory is not in your Windows User Path, add it. See Installing DSim Cloud on Windows.


If Windows is blocking DSim Cloud CLI commands, add mdc.exe to the Windows Security Exclusion list and reinstall DSim Cloud CLI:


1. Type "security" in the Windows Search Box and click the Windows Security App.



2. Click Virus & threat protection.



3. Under Virus & threat protection settings, click Manage settings.



4. Scroll down to Exclusions and click Add or remove exclusions.



5. Allow Windows Security to make changes to your device if necessary.


6. Click Add an exclusion.



7. Select File, navigate to C:\Users\<user>\AppData\Local\metrics\mdc.exe, and click Open.


8. Close Windows Security.


9. Reinstall the DSim Cloud CLI.



Cause:

Windows blocks DSim Cloud because it deems mdc.exe as a security threat.



Related info:

Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select at least one of the reasons
CAPTCHA verification is required.

Feedback sent

We appreciate your effort and will try to fix the article